Action Required: Please re-login to Microsoft 365

Incident Report for CentricFlow

Resolved

This incident has been resolved.
Posted May 08, 2025 - 04:15 UTC

Update

If you browse to Apps > Integrations, you can re-login. If you have any issues reconnecting, if you click the 'Having problems? Click here to disconnect' below the status message, this will remove the expired token and allow you to reconnect
Posted May 05, 2025 - 16:07 UTC

Monitoring

We have recently updated our Microsoft 365 integration. To continue using Microsoft 365 without interruption, you may need to log out and sign back in to your Microsoft 365 account.

Thank you for your understanding!
Posted May 05, 2025 - 16:05 UTC
This incident affected: Microsoft 365 (Emails).