Delays in outbound email delivery

Incident Report for CentricFlow

Resolved

This incident has been resolved.
Posted Jul 15, 2025 - 07:14 UTC

Update

We can now see emails are beginning to be processed by our provider now, we will be continuing to monitor this over the next few hours and escalate, if required.
Posted Jul 14, 2025 - 15:33 UTC

Update

We are currently awaiting an update from our mail provider and will update once we hear back.

Thank you for your patience.
Posted Jul 14, 2025 - 12:59 UTC

Monitoring

We are monitoring the outbound emails and can see they are now flowing. There are some delays due to the queuing of emails because of this issue and will provide a further update when we can see the queue has returned back to normal.

Thank you for your patience.
Posted Jul 14, 2025 - 10:12 UTC

Identified

We have identified the cause of the delays and are working with our supplier to ensure they can get this issue resolved.

We’ll provide another update when new information becomes available.

Thank you for your patience.
Posted Jul 14, 2025 - 07:16 UTC

Investigating

We are currently investigating an issue causing delays in outbound email delivery from our platform. This may affect system notifications, password resets, and other automated communications.

We’ll provide another update when new information becomes available.

Thank you for your patience.
Posted Jul 14, 2025 - 06:55 UTC
This incident affected: Email Relay.